I need help ASAP!!! - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Newbie/General Forum
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Newbie/General Forum Beginner/basic questions and general EVO discussion. Specific questions should be asked in a focused forum below. This area is for the newbies.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 01-03-2012, 01:40 PM   #1 (permalink)
EVOtuners Member
 
Club Region: Rocky Mountain
Registered: Dec 2011
Posts: 5
Reputation: boostoholic is an unknown
Garage
I need help ASAP!!!

just bought an 03 evo, and a few days ago it crapped out on me. car sputters, and doesnt make any power at all. it will start bucking and surging, and then stalls out. idle is very erratic. in 1st gear at half throttle rpms wont raise, but the turbo begins to spool right before the bucking and surging begins. could not get the car above 15 mph. ive replaced the 5 yr old battery, and the MAF sensor with no change. i was able to drive the car home with the maf sensor unplugged, but drivability was horrible. drove 8 miles and it used nearly a 1/4 tank of fuel.

modifications:
AEM intake and filter, Injen IC piping, Greddy BOV, Greddy profec spec II, 3" catback exhaust.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-07-2012, 01:30 PM   #2 (permalink)
EVOtuners Member
 
Club Region: Rocky Mountain
Registered: Dec 2011
Posts: 5
Reputation: boostoholic is an unknown
Garage
well... just fyi, dealership is taking care of it. havent had my car in over a week. dont know what the problem is.
Offline   Reply With Quote
Old 02-10-2012, 11:25 PM   #3 (permalink)
EVOtuners Member
 
Club Region: Rocky Mountain
Registered: Dec 2011
Posts: 5
Reputation: boostoholic is an unknown
Garage
alright. nearly 2 months later, car still isnt road worthy. car is in somewhat better shape now, but still cant rev more than 2800 rpm before i sputter out. maf sensor, crank sensor, wastegate and bov have all been replaced now. turbo spools up, no strange noises. it seems to go lean under throttle. can only make about 3-4 psi before it cuts out. any ideas? a repsonse would be great.
Offline   Reply With Quote
Old 02-14-2012, 01:53 PM   #4 (permalink)
EVOtuners Member
 
Club Region: Rocky Mountain
Registered: Dec 2011
Posts: 5
Reputation: boostoholic is an unknown
Garage

heres a video of it
Offline   Reply With Quote
Old 04-09-2012, 09:49 AM   #5 (permalink)
EVOtuners Member
 
Club Region: New England
Registered: Apr 2012
Posts: 1
Reputation: John_Carter6777 is an unknown
That's really strange. I wish I could help. I'm glad you're keeping this thread updated, but I hope it gets figured out for you soon.


__________________
Cruisin' around in the Evo.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 07:26 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.