Ignition Coils - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Newbie/General Forum
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Newbie/General Forum Beginner/basic questions and general EVO discussion. Specific questions should be asked in a focused forum below. This area is for the newbies.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 04-22-2010, 12:08 AM   #1 (permalink)
EVOtuners Member
 
Car: 03 EVO
Club Region: Midwest
Registered: Jun 2009
Posts: 14
Reputation: street_lethal is an unknown
Ignition Coils

Does anybody know if the MD362907 ignition coils can be used on an evo 8? I've read that evo 7,8,9's use MD363552 ignition coils but some websites claim that the 2003 evo 8 uses the MD36207 coils. Has anybody tried using the MD362907 coils, which are commonly used in other mitsus and some chyslers too?
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-22-2010, 07:29 AM   #2 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
have you called the dealer with your vin to see which part # your car takes? Alot of mitsu part number superced into a another number. Can I ask why you are changing your coils? if so how many miles do you have? What issues are you have with the car?
Offline   Reply With Quote
Old 04-22-2010, 10:01 PM   #3 (permalink)
EVOtuners Member
 
Car: 03 EVO
Club Region: Midwest
Registered: Jun 2009
Posts: 14
Reputation: street_lethal is an unknown
I'll try calling the dealer today. I'm thinking about changing out he coils because of my check engine light. The code reads a ramdom missfire, which could be caused by a lot of different things. I changed out the spark plugs and got a boost leak and vaccum leak test done. I still get the check engine light after some driving. I'm not really sure how long the stock coils are suppose to last, but I have 60K on them. Some websites recommend changing the boost of the coil first, but i figure I might as well change the whole damn thing while I'm at it.
Offline   Reply With Quote
Old 04-23-2010, 03:56 AM   #4 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
reccomend changing the boost? if your car is a 03 did it ever get the updated flash for the p0300 code. the older evo 8's are notorious for it. hell mine goes off about every 2 months.

What plugs did you install and were they gapped properly? believe it or not the evo really is picky about plugs. best ones to use are the NGK iridiums. what mods are on the car so i can give you the proper part number for which plug you should be using.

Can you hear or feel the car misfire? plugs and wires are cheaper to replace then those 2 coils.

What was the result of your boost leak test? also have you had the timing checked at the crank? when mine was missing real bad i swapped everything, turned out my tensionor gave a little bit and i was off by 8degrees at the crank, at 9 the motor goes boom! something to think about. have you have your t-belt service yet?
Offline   Reply With Quote
Old 04-23-2010, 09:56 AM   #5 (permalink)
EVOtuners Member
 
Car: 03 EVO
Club Region: Midwest
Registered: Jun 2009
Posts: 14
Reputation: street_lethal is an unknown
Sorry, changing the boot of the coil was what I ment. And no, i haven't had an eupdated flash, does the dealership do that you think? I use the NGK bpr7es plugs gapped at 0.032. I really don't have any mods, just a stage 2 execedy clutch, k&n drop in filter, and evo 9 diverter valve. I only feel the misfire at highway speeds over 70mph. I only had a small leak from small vaccum line of the diverter valve. Haven't had my timing belt looked at yet.
Offline   Reply With Quote
Old 04-23-2010, 12:11 PM   #6 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
your plugs are gapped way huge, try .026-.028 and get rid of the copper plugs, they can foul out very quickly. go with the br7eix gapped at .026-.028 and i bet it runs 10 times better. when i swapped from the 7es coppers to the br7eix iridiums i gained 12whp.......
Offline   Reply With Quote
Old 08-25-2010, 12:52 AM   #7 (permalink)
EVOtuners Member
 
Club Region: Southwest
Registered: Aug 2010
Posts: 3
Reputation: MichaelFoster is an unknown
Why are you changing your ignition coil? Does it has an ignition coil cover? Different cars have different specs. Try finding the right number so that we can tell if it fits or not.

Last edited by MichaelFoster; 08-26-2010 at 05:48 PM.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 03:51 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.