Just bought an 03 EVO - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Newbie/General Forum
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Newbie/General Forum Beginner/basic questions and general EVO discussion. Specific questions should be asked in a focused forum below. This area is for the newbies.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 08-01-2010, 02:56 PM   #1 (permalink)
EVOtuners Member
 
Car: 03 EVO
Club Region: Gulf Coast
Registered: Jul 2010
Posts: 2
Reputation: tigerrag88 is an unknown
Just bought an 03 EVO

Hey guys, new to the evo world. Let me start off by saying holy SH*T this car is nothing short of amazing. From the handling and acceleration to just the pure enjoyment you get out of just driving around the city. I bought my yellow Evo VIII last week with 24k on it. The car is mostly stock, except for a minor turbo upgrade which I still dont know any specifications or what type of turbo it has. Car has about 100 miles on new "stage 4"boo clutch and the turbo is almost brand new from what I understand. The car needed new battery terminals when i bought it, which I ordered from Mitsubishi and I installed them myself. After a week of driving and putting nearly 500 miles on her, I've ran into a few issues.

1.) The car scares me sometimes when starting. When it hasnt been run for a while, say, over night, it starts right up with only about 2 cranks from the starter. But if it has only been an hour or so between startups, sometimes it cranks almost to the point of going completely dead. A few days ago I didnt even get a battery click. Not sure if it needs a new battery or its an issue thats caused by something else.

2.) I went to my parents over the weekend which is about a 60 mile drive one way. About half way there at 75mph, i felt a sudden loss of power, almost like a sudden jolt, and when i pushed down the gas to get back up to speed, the car started violently vibrating and noticed the boost guage read .29 at 75mph rather than the -7 it was at up until that point. I let off the gas a few times and it would go away but come right back after about 45 seconds.

and 3.) every now and then the idle will dip down to 500rpm at a stop light and actually died on me once when i went to shift into first from a stop.

The guy who owned the car only told me it had an upgraded turbo and that if I ran it on the 22psi preset on the bc, it would run at about 400awhp. its set at 19 currently. It has an aem shortram and stock exhaust. Thats about it. The guy took very good care of the car and worked off shore in suadi which is why it has such low miles for an 03'. I would appreciate any imput from you guys because like I said, I'm new to the evo and really don't know much about it other than the basics. I did do a search but it really didnt help me out much.


ps. One more thing, I smell something weird after its been running but only when the car is turned off. Smells like oil almost but there are no oil puddles and I've looked as best as I could and I dont see any oil on the motor.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-02-2010, 12:00 PM   #2 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
Congrats on the purchase.

the good: sounds like you have a great staring platform
the bad: just because its got low miles does not mean it will be easy.

1. with it being a 03 its passed its 5 year life span that the OEM battery is rated for under regulat condiditons. My OEM battery from 03 went out late last year, and i drive my car everyday.
2. what do you mean vibrating violently? i would bet you have a boost leak you may want to test it and check it out. do you have a air fuel ratio gauge?
3. what other mods does the car have? this could be caused by being improperly tuned or having the wrong type of BOV on it, or not being adjusted right.


Why would you upgrade a turbo before doing supporting mods, like injectors, fuel pump, FMIC, TBE.....

You need to find out more about what was actually done to the car before you run it hard or maybe even drive it daily. there are a lot of red flags from what you have posted. get the real info and get back to me. post up some pics of the car and under the hood and i can try to help.
Offline   Reply With Quote
Old 08-03-2010, 08:10 PM   #3 (permalink)
EVOtuners Member
 
Car: 03 EVO
Club Region: Gulf Coast
Registered: Jul 2010
Posts: 2
Reputation: tigerrag88 is an unknown
Ok, so ive got a little more info on the car and mods. No I dont have an air/fuel guage yet, but plan on getting one in a few weeks. Bringing the car to get tuned in New Orleans in a few weeks.
Mods are as followed:
20g dual puck 10.5 TME Turbo
AEM shortram
stock injectors
stock tune
AEM Boost guage/controller
4 puck clutch.

From what the shop told me, Its in serious need of a tune with that big of a turbo on the car. The reason it hasn't been tuned is because after the previous owner had the turbo/intake installed, he got shipped to saudi for 10 months and when he came back he just decided to sell it instead of drop more mony on the car. Any more input from you guys would be appreciated. Thanks

btw, bought a new battery today...starting problem = fixed
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 07:08 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.