Mitsubishi evo V problem please help - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Newbie/General Forum
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Newbie/General Forum Beginner/basic questions and general EVO discussion. Specific questions should be asked in a focused forum below. This area is for the newbies.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 09-10-2013, 01:20 PM   #1 (permalink)
EVOtuners Member
 
Club Region: SoCal
Registered: Sep 2013
Posts: 2
Reputation: emadbo2tor is an unknown
Mitsubishi evo V problem please help

Hello, I just got an evo V , I experience a problem and I cannot identify the causes so please the help of anyone experienced will be greatly appreciated**
1- Irregular Engine sound which causes vibration inside the car
2- When I start walking with the car on low RPMs (0-2) I slightly press the gas pedal and fix the pedal on that slight press, the car starts jerking severely as if i'm pushing and pulling my feet on and off the pedal. It was fine on high RPMs until a couple of days it started to jerk on higher RPMs (3-7) HINT: when I remove the mass airflow sensor's plug and drive the car , these symptoms disappear , I replaced it with another (thinking this would fix the problem) but nothing changed.
3-While accelerating when I push my feet on the pedal (RPM should rise) it rises and the car accelerates, however if i pulled my feet and pushed it quickly the car stops responding and RPM falls to near idle without me removing my feet from the pedal !!
4- Yesterday I tried driving the car on high rpms after i tried it , the engine's sound changed as if something's really wrong so I stopped and pushed the gas to check the sound clearly I discovered that the RPM won't rise after 3(000) and the car became extremely weak as if i'm driving a 10 HP car !!!!!
5-Before this, hearing fuel bombs from time to time was normal

Thanks for reading , your help will be sincerely appreciated !!!
https://www.facebook.com/Emad.Bo2tor
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-22-2019, 10:51 AM   #2 (permalink)
EVOtuners Member
 
Registered: Sep 2019
Posts: 1
Reputation: WmMorgan is an unknown
The actuator is known to fail on the Lancer Evolution. If you are finding that the car is having sudden jolts or boosts after a slight power loss at high revs, the actuator is the cause of your problem. When you turn the climate control on are you getting a fishy smell? If so, the evaporator drain hole will be blocked. This is a common occurrence on these vehicles.


__________________
https://autoportal.com/newcars/skoda/rapid
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 04:22 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.