No Heat! Help Me Plz? - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Newbie/General Forum
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Newbie/General Forum Beginner/basic questions and general EVO discussion. Specific questions should be asked in a focused forum below. This area is for the newbies.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 05-12-2010, 04:42 PM   #1 (permalink)
EVOtuners Member
 
CraZyx978's Avatar
 
Club Region: New England
Registered: May 2010
Posts: 17
Reputation: CraZyx978 is an unknown
No Heat! Help Me Plz?

Sorry if i post this on the wrong section.. I have no heat in my evo.. it just blow of warm air. Wen i put it on ac it's cold so it just the heat. i check the 2 cable the blue and white one there all connected.. I also checked all my fused seem to be working.. Can someone please help me out? thanks..
Oh and also my temp on my cluster don't work either. i mean it worked b4. but out of nowhere it just stop working... and input on that also? thanks..
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-13-2010, 05:40 AM   #2 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
so you have 2 seperate issues? your temp gauge in the gauge cluster stopped working and your heat doesnt work. does you hot to cold knob turn freely? the cables can snap where they connect to the hvac box or system, causing you to get no heat. has your car been losing any coolant randomly here and there?
Offline   Reply With Quote
Old 05-14-2010, 09:03 PM   #3 (permalink)
EVOtuners Member
 
CraZyx978's Avatar
 
Club Region: New England
Registered: May 2010
Posts: 17
Reputation: CraZyx978 is an unknown
well i don't no if i'm losing coolant or not but my knob doesn't turn freely wen i turn to to cold on max it's goes all da way and u feel a lil click but wen i turn to hot all da way it goes but it turns back a lil doesn't go all the way to max.. can the cable be snap? how hard is it to change dat? also how about my cluster my temp just stop workin outta nowhere..
Offline   Reply With Quote
Old 05-15-2010, 12:02 PM   #4 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
yhe cable or the linkage or gears could be binding. you may want to check your coolant too. there was a tsb for the cable and linkage. contact your dealer for more info and parts you may need to fix. Some just needed a cable and new gears. and then some needed a new hvac box which requires pulling the dash.
Offline   Reply With Quote
Old 05-16-2010, 05:49 PM   #5 (permalink)
EVOtuners Member
 
CraZyx978's Avatar
 
Club Region: New England
Registered: May 2010
Posts: 17
Reputation: CraZyx978 is an unknown
dam i do not want to rip da dash out lol.. but how can i check to see if the cable and new gears needs to be replace?
Offline   Reply With Quote
Old 05-17-2010, 03:18 AM   #6 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
you can check out the gears if you look on the driverside of the center console/ partially under the dash, it could be missing teeth off the gears. they are white plastic. to check the cable you need to remove the hvac panel and look where the cable connects to the hot cold knob.
Offline   Reply With Quote
Old 05-18-2010, 12:47 PM   #7 (permalink)
EVOtuners Member
 
CraZyx978's Avatar
 
Club Region: New England
Registered: May 2010
Posts: 17
Reputation: CraZyx978 is an unknown
im new to evo i know NOThing about them.. lol. so if you could can u please show me a pic of what the gears and the hvac box looks like? thank you very much kind sir
Offline   Reply With Quote
Old 05-18-2010, 01:36 PM   #8 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
i dont have a pic of mine right now. you will have to remove the driverside part of the center console partially under the dash and its there. I will see if I can get some pics at some point.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 05:57 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.