spark plug - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Newbie/General Forum
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Newbie/General Forum Beginner/basic questions and general EVO discussion. Specific questions should be asked in a focused forum below. This area is for the newbies.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 10-14-2007, 06:28 PM   #1 (permalink)
 
Registered: Sep 2007
Posts: 5
Reputation: V8KillaLL is an unknown
Question spark plug

i just replaced the spark plug and now when im at fulll throttle it feels like im going to stall like if the car is laggingi just wanted to know how to fix the issue please someone help me
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-14-2007, 06:43 PM   #2 (permalink)
 
Warrtalon's Avatar
 
Timeslip: 11.510 @ 115.12
Dynosheet: 367whp/386 lb-ft
Club Region: Rocky Mountain
Registered: Apr 2005
Posts: 3,506
Images: 12
Reputation: Warrtalon is an unknown
Send a message via AIM to Warrtalon
What do you mean by _the_ spark plug? We have 4 spark plugs, so are you saying you changed all 4 spark plugs? What exact brand and part number did you install, and what was the gap you used?

As for the problem, can you explain it in MUCH more detail?

- what gear?
- what rpm?
- what boost?
- what exactly do you mean by "going to stall" and "lagging"?
- what do you hear?





__________________
[email protected] - PMI
[email protected] - Bandi
Offline   Reply With Quote
Old 10-14-2007, 07:02 PM   #3 (permalink)
 
Registered: Sep 2007
Posts: 5
Reputation: V8KillaLL is an unknown
i used the ac delco spark plugs but i dont know the part number i replaced all four of them.It happen in every gear and it only happens when im at full throttle.I dont know what boost it is cuz i dont have a boost gauge. It only happens when im in full throttle and when im cruising at high rpm's it doesnt do it and when i stomp on it feels like it im getting whip lash
Offline   Reply With Quote
Old 10-14-2007, 07:13 PM   #4 (permalink)
 
Registered: Apr 2005
Posts: 442
Images: 2
Reputation: JustDSM is an unknown
Get yourself some NGK BPR7ES gapped about .026"

Get a boost gauge too
Offline   Reply With Quote
Old 10-14-2007, 07:15 PM   #5 (permalink)
 
Registered: Sep 2007
Posts: 5
Reputation: V8KillaLL is an unknown
are they really good spark plugs? the boost gauge thats a must that should come in a month
Offline   Reply With Quote
Old 10-14-2007, 08:18 PM   #6 (permalink)
 
Registered: Apr 2005
Posts: 442
Images: 2
Reputation: JustDSM is an unknown
They're alot better than the AC Delco plugs, that's for sure!
Offline   Reply With Quote
Old 10-14-2007, 08:25 PM   #7 (permalink)
 
Registered: Aug 2007
Posts: 862
Reputation: Coevopower is an unknown
Thats ur problem u went with cheap ol sparks plugs, mitsubishis along with nissans do it alot when you dont use NGK spark plugs. not sure why, but its pretty much a must to use NGK7.
Offline   Reply With Quote
Old 10-14-2007, 08:32 PM   #8 (permalink)
 
Warrtalon's Avatar
 
Timeslip: 11.510 @ 115.12
Dynosheet: 367whp/386 lb-ft
Club Region: Rocky Mountain
Registered: Apr 2005
Posts: 3,506
Images: 12
Reputation: Warrtalon is an unknown
Send a message via AIM to Warrtalon
Whoa, what the hell? AC Delco????? No way!

Yeah, get NGK BPR7ES from Autozone or Advanced Auto (or wherever) and gap them to .026. Is there a reason you changed the plugs, though? Don't need to change them unless they've fouled out...





__________________
[email protected] - PMI
[email protected] - Bandi
Offline   Reply With Quote
Old 10-15-2007, 01:32 PM   #9 (permalink)
 
Registered: Sep 2007
Posts: 5
Reputation: V8KillaLL is an unknown
one really fouled out
Offline   Reply With Quote
Old 11-01-2007, 11:09 PM   #10 (permalink)
 
Registered: Aug 2006
Posts: 163
Images: 7
Reputation: yangs4ever4g63 is an unknown
ngk all the way

I installed my ngk spark plugs awhile ago... wasn't sure what model and number but they were a later model then the stock ones. Never installed spark plugs in before so I just took the old ones out and put the new ones in. Was there all to it? Its in tight so far. Just waiting to put my clutch in in the future. Projext_Yang4g63
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 11:30 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.