having a huge problem with noise - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Drivetrain Tech
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Drivetrain Tech Transmission, clutch, flywheel, driveshaft, gears, differentials, transfer case, shifter, etc.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 10-08-2010, 07:51 PM   #1 (permalink)
EVOtuners Member
 
Car: 03 EVO
Club Region: Tri State
Registered: Aug 2010
Posts: 2
Reputation: MRevOguy is an unknown
having a huge problem with noise

ok well i just got a my evo about 3 months ago and ive been hearing whiining noises from the t case. i barely ever drive my car hard cuz its my only car so i drive it cautious and careful all the time sometimes i get on it but nothing serious. so last night im driving home from work and normally when i decelarate i dont hear anything but this time it was this awful noise like its grinding and when i come to a stop or take it out of gear it stops but now its even worse im not driving it anymore till i figure it out i really need some help
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-09-2010, 07:46 AM   #2 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
have you checked or swapped the fluid lately? you may want to have a trans shop look at it too. it could be something big or something small. how many mods and how many miles? where are you located at? maybe there is a good shop near you that can help out.


__________________
discounttiredirect.com
eibach.com
LB Design
Offline   Reply With Quote
Old 10-09-2010, 05:57 PM   #3 (permalink)
EVOtuners Member
 
Car: 03 EVO
Club Region: Tri State
Registered: Aug 2010
Posts: 2
Reputation: MRevOguy is an unknown
im in virginia beach im thinking it could be the fluid but i dont know yet i gotta wait till monday
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 03:03 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.