transfer case and input shaft - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Drivetrain Tech
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Drivetrain Tech Transmission, clutch, flywheel, driveshaft, gears, differentials, transfer case, shifter, etc.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-28-2009, 11:36 AM   #1 (permalink)
EVOtuners Member
 
Club Region: NorCal
Registered: Sep 2009
Posts: 35
Images: 3
Reputation: jayviet is an unknown
transfer case and input shaft

Alright so my evo 9 mr went downhill. i first bought the car with 5000 miles. and replaced the clutch with a stage 4 act 6puck clutch.
and it was leaking throuugh passenger side axle cause the seal broke. so my dad said he would take care of it but he put in the wrong fluid.
instead of putting ACD fluid he put ATF fluid. but i didnt know cause they both were the same color. so i drove it for 6 months.
one day i was driving and i stepped on my clutch and it didnt come back up. so i took to a place that took it apart.
My TOB,pressureplate clutch flywheel were gone. i replaced everything. it drives fine now but theres a loudass rumbling noise that i think is come from the transfer case.
the noice gets louder when i increase my speed. the reason i dont think its my tranny because nomatter what gear its in the rumble is always there.

does anybody have an idea of what else could be wrong.

oh and my imput shaft bearring is messed up and will need to be replaced.
would it be smarter to go after market?
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-28-2009, 02:25 PM   #2 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
you should have done it right the first time, atf in a 6spd with LSd doesnt sound good at all. Did you launch your car in those 6 months? Honestly i'm shocked it lasted that long.....only use OEM fluid or fluids known to work in the evo tranny and t-case. I would say you are gonna need a t-case and maybe some other stuff.
Offline   Reply With Quote
Old 12-29-2009, 04:56 AM   #3 (permalink)
SUPER MODERATOR
 
Car: 06 EVO
Club Region: Outside North America
Registered: Dec 2008
Posts: 366
Reputation: You can trust this leader of the site
Send a message via AIM to rookhoe
Wait, he put automatic transmission fluid in the transmission? Youre definately in need of having work done. T-Case and Tranny. I feel sorry for you man, but unless you really know how to do the work yourself, you might want to start saving money so you can get this fixed.

I also suggest you stop driving it until the problem is resolved.


__________________
06 GG Evo SE

I WANNA GO FAST
Offline   Reply With Quote
 
Old 12-31-2009, 10:52 PM   #4 (permalink)
EVOtuners Member
 
Club Region: NorCal
Registered: Sep 2009
Posts: 35
Images: 3
Reputation: jayviet is an unknown
will anything else get messed up cause i really need transpotation. if nothing else will break then i dont mind driving with the noise but if something else is gonna break then i wont take the chances
Offline   Reply With Quote
Old 01-01-2010, 05:12 AM   #5 (permalink)
SUPER MODERATOR
 
Car: 06 EVO
Club Region: Outside North America
Registered: Dec 2008
Posts: 366
Reputation: You can trust this leader of the site
Send a message via AIM to rookhoe
Its just going to get worse. Its your drivetrain bro. You can't expect that noise, while driving it, to be healthy.


__________________
06 GG Evo SE

I WANNA GO FAST
Offline   Reply With Quote
Old 01-01-2010, 07:32 AM   #6 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
have all the fluid swapped out at a dealer here at my dealer thats about $100 for a AWD sfluid swap.
Offline   Reply With Quote
Old 02-09-2011, 08:12 PM   #7 (permalink)
EVOtuners Member
 
Car:
Club Region: Mid Atlantic
Registered: Jan 2011
Posts: 4
Reputation: jansengeorge is an unknown
transfer case switch..

It all started when I was driving the lights and radio started to flicker on and off as if a battery cable was loose. I went home turned off the truck checked the battery and it was fine and when I turned the truck back on the FWD service light was on. I replaced the transfer case switch and I am not pulling any codes from my code reader, I am thinking a loose wire? Any suggestions?

Last edited by jansengeorge; 02-11-2011 at 10:47 PM.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 02:54 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.