Can't launch w/o burning clutch - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Racing Forums > Drag Strip Tech
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Drag Strip Tech For sanctioned, legal Drag Racing. Preparation, technique, tips, and stories from the events. Tell us about your last event. No street racing discussions.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 07-02-2005, 08:02 PM   #1 (permalink)
 
Registered: Jun 2005
Posts: 15
Images: 4
Reputation: gt420hp is an unknown
Can't launch w/o burning clutch

I ran for the first time the EVO at the track. I am so used to 1.60 sixty's in my Mustang, and I ran a 2.597, 2.672, and a 2.751 on my stock EVO....

I was so pissed, on the way home I launched the car at 4500 and feathered the clutch...it shot out like a rocket....but it smelled so bad...thought the car was on fire.

I can't burn the clutch up everytime I want to have a good 60 ft. Is there any way to spool the turbo at lower RPM's? or maybe try a shot of NOS at launch....something to get this car going....

Or is a race clutch the best answer...

My MPH at the end of the 1/4 was 96.58 to 98.04
but the ET's sucked 14.822, 14.824
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-02-2005, 09:12 PM   #2 (permalink)
 
Registered: Feb 2004
Posts: 718
Images: 10
Reputation: Fourdoor is known to be trustworthy and helpfulFourdoor is known to be trustworthy and helpful
Best way to launch a stock EVO is to pulse the throttle between 4500 and 5500 over and over at the tree, and feather out the clutch at the high end (5500 RPM). That will give you the best results..... not sure how long the stock clutch will last doing that on a regular basis though. Looking at your traps, looks like those 19" wheels are killing you though. They may be pretty, but they are also heavy as hell

Keith
Offline   Reply With Quote
Old 07-03-2005, 06:58 AM   #3 (permalink)
 
Registered: Jun 2005
Posts: 15
Images: 4
Reputation: gt420hp is an unknown
you are right about the wheels...they look nice. They came with the car when I bought them. I am looking for some stock 17's Enkei's to put on the car.
Offline   Reply With Quote
 
Old 07-12-2005, 08:09 PM   #4 (permalink)
 
Registered: Jun 2005
Posts: 15
Images: 4
Reputation: gt420hp is an unknown
I got the launch down better now. 1.9 sixty foot...not great...but much better than the first day out. Should have my mods within a month...and hope to have to car in the low 12's...
Offline   Reply With Quote
Old 07-12-2005, 08:25 PM   #5 (permalink)
 
Registered: Feb 2004
Posts: 718
Images: 10
Reputation: Fourdoor is known to be trustworthy and helpfulFourdoor is known to be trustworthy and helpful
Quote:
Originally Posted by gt420hp
I got the launch down better now. 1.9 sixty foot...not great...but much better than the first day out. Should have my mods within a month...and hope to have to car in the low 12's...
What did you end up running with the better 60' time?

Keith
Offline   Reply With Quote
Old 07-12-2005, 08:32 PM   #6 (permalink)
 
Warrtalon's Avatar
 
Timeslip: 11.510 @ 115.12
Dynosheet: 367whp/386 lb-ft
Club Region: Rocky Mountain
Registered: Apr 2005
Posts: 3,506
Images: 12
Reputation: Warrtalon is an unknown
Send a message via AIM to Warrtalon
Quote:
Originally Posted by Fourdoor
What did you end up running with the better 60' time?
Probably the time in his sig/profile on the left, since his previous mph were less than 100.





__________________
[email protected] - PMI
[email protected] - Bandi
Offline   Reply With Quote
Old 07-13-2005, 07:01 AM   #7 (permalink)
 
Registered: Jun 2005
Posts: 15
Images: 4
Reputation: gt420hp is an unknown
Yes..my best time on the 1.9 sixty is shown on my sig...and also in the 1/4 mile time gallery. My sixty's before were 2.5, 2.6 ...when I didn't know how to launch correctly. Once the launches become second nature...I'll go back to working on the reaction time.
Offline   Reply With Quote
Old 07-13-2005, 09:50 AM   #8 (permalink)
 
Warrtalon's Avatar
 
Timeslip: 11.510 @ 115.12
Dynosheet: 367whp/386 lb-ft
Club Region: Rocky Mountain
Registered: Apr 2005
Posts: 3,506
Images: 12
Reputation: Warrtalon is an unknown
Send a message via AIM to Warrtalon
Quote:
Originally Posted by gt420hp
Yes..my best time on the 1.9 sixty is shown on my sig...and also in the 1/4 mile time gallery. My sixty's before were 2.5, 2.6 ...when I didn't know how to launch correctly. Once the launches become second nature...I'll go back to working on the reaction time.
You still have a ways to go on the launch, so keep working on it. Don't be satisfied until you're pulling consistent 1.7x 60's (stock clutch) or 1.6x 60's (aftermarket clutch). If you are doing this on the stock clutch (I forgot), then get ready to replace it, because it's pretty weak and will stop working soon due to the hotspots created by the slipping. I turned my flywheel and pressure plate into mirrors from too many hard launches and 12.2-12.3 1/4-mile times. Interestingly, the clutch disk still had have its life remaining, haha.

Unless you're planning on bracket racing or heads-up import competitions, don't worry about reaction time, since it does not affect your et/mph.





__________________
[email protected] - PMI
[email protected] - Bandi
Offline   Reply With Quote
Old 07-18-2005, 04:10 PM   #9 (permalink)
 
Registered: Apr 2005
Posts: 14
Reputation: jmartinez1170 is an unknown
learn how to drive the car first then take it to the track
Offline   Reply With Quote
Old 12-08-2005, 03:36 PM   #10 (permalink)
 
Registered: Nov 2005
Posts: 24
Reputation: raceguy05 is an unknown
You're gonna have to shift alittle faster to get a better time. Don't slip the clutch as much cause that's why it's burning up but don't dump it either cause it'll bog down. . .
Offline   Reply With Quote
Old 02-05-2006, 05:33 AM   #11 (permalink)
 
Registered: Feb 2006
Posts: 27
Reputation: robert martai is an unknown
my clutch is died whe i got the 290 whp. ihad to change it because started slipping almost everytime i lunched it.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 07:26 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.