Car Problems... - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Tuning & Engine Management
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Tuning & Engine Management Engine Management, EGT temps, timing, wideband, datalogging, fuel trims, etc.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 06-09-2005, 08:45 PM   #1 (permalink)
 
Registered: May 2005
Posts: 134
Reputation: CArkid0101 is an unknown
Car Problems...

Hey guys, i got my evo a few weeks ago and today i was driving and two things happened. Im kinda nervous about both. The first thing is when i get to 6000 to 7200 rpm something makes a high pictched whisling noise. Kinda like an air leak. I feel a slight de-accel also. I dont have a boost gauge yet so i cant tell you how my boost level drops. Any Ideas?
Second thing. My right 3 gauges in the console go out. No light. The "Lancer", the fuel, and the one above fuel. They all go out. But come back on. I was low on gas, filled up, then they worked for my short ride home. I dont think it should matter, but im just explaining the situation. Please help me out with these problems, im new to imports, and am a bit nervous about the situation. The car has 29,000 miles. Thanks Guys
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-09-2005, 09:39 PM   #2 (permalink)
 
Warrtalon's Avatar
 
Timeslip: 11.510 @ 115.12
Dynosheet: 367whp/386 lb-ft
Club Region: Rocky Mountain
Registered: Apr 2005
Posts: 3,506
Images: 12
Reputation: Warrtalon is an unknown
Send a message via AIM to Warrtalon
Quote:
Originally Posted by CArkid0101
Hey guys, i got my evo a few weeks ago and today i was driving and two things happened. Im kinda nervous about both. The first thing is when i get to 6000 to 7200 rpm something makes a high pictched whisling noise. Kinda like an air leak. I feel a slight de-accel also. I dont have a boost gauge yet so i cant tell you how my boost level drops. Any Ideas?
Second thing. My right 3 gauges in the console go out. No light. The "Lancer", the fuel, and the one above fuel. They all go out. But come back on. I was low on gas, filled up, then they worked for my short ride home. I dont think it should matter, but im just explaining the situation. Please help me out with these problems, im new to imports, and am a bit nervous about the situation. The car has 29,000 miles. Thanks Guys
We got this one figured out. Now let me answer your other post.

Btw, for everyone else, the answer to this was that his intake snorkel was not fastened down, which caused it to suction up against the hood when the air flow reached a certain point (6k+ rpm). When this happens, the engine is starved for air, and the little bit of air that does get through the tiny opening causes a loud whistle sound. The lack of air causes a quick drop in boost and subsequent power...

I only know because I it took me a week to troubleshoot this same problem, and I never would have figured it out if not for a few guys on EvoM who told me to check the snorkel.



Offline   Reply With Quote
Old 06-09-2005, 10:19 PM   #3 (permalink)
 
Registered: May 2005
Posts: 134
Reputation: CArkid0101 is an unknown
as i said on evom, thx a ton, i owe yea one. I started gettin freaked out. Thx again man!
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 03:37 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.