Launch Control kick in while driving.. pls help - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Tuning & Engine Management
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Tuning & Engine Management Engine Management, EGT temps, timing, wideband, datalogging, fuel trims, etc.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 07-05-2009, 06:31 AM   #1 (permalink)
 
Registered: Jul 2009
Posts: 1
Reputation: infinixi is an unknown
Launch Control kick in while driving.. pls help

Hi ,

im helping this problem, my launch control seems to be activated at 4000 rpm while driving. i couldnt drive above 4000rpm at all gear and backfire sound can be heard from exhaust.

my ride is evo 9 GSR, im using autronic SM4 ECU and my tuner set my launch control at 4000rpm.

at stop, launch control kick in at 4000rpm( as set ), but my launch control seems to kick in while driving and i couldnt drive beyond 4000rpm.

what can be the cause of this? kindly help.

thks

stressed.......
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-05-2009, 04:43 PM   #2 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
I have no idea what the sm4 ecu is or what your tuner did. Most of us here in the states use ecuflash which is a free program to tune your OEM ecu and everyone has had incrediable results. Why is your launch set 4k? OEM should have 5k and most of us set ours at 6k that way we can leave the line with 10-15psi. Have your tuner check out the map. On the OEM ecu the launch control works because it will have the launcg control kick in only when there is no speed being read by the ecu...when there is speed being read on the ecu it lets you got to your set redline. does your car have a antilag system on it? maybe have another tuner check your car out. I would seriouly consider going back to controlling everything from the stock ecu. if you want the free ecuflash program go to openecu.org for the program and all the details. There is also a good basic write up on this site for it.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 07:25 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.