new fuel system and now something is wrong - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Tuning & Engine Management
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Tuning & Engine Management Engine Management, EGT temps, timing, wideband, datalogging, fuel trims, etc.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 07-07-2009, 10:02 AM   #1 (permalink)
 
Registered: Jun 2009
Posts: 4
Reputation: dsmgrimreaper is an unknown
new fuel system and now something is wrong

ok i installed a new walbro 255 pump and a junk obx fuel rail delfi 750 injectors. the car started right up no problems what so ever but now the car spitts and sputters at about 5,000 5,500rpms. i have check vacuum lines over and over again i turned the boost down to 8-10psi and still no change need help bad
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-07-2009, 10:15 AM   #2 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
Have you retuned the car for the bigger fuel pump and injectors? Also the Fuel rail should be flowing more. Are you using a stock fuel pressure regulator? Does it only spit and sputter at wide open throttle? If so you need to change your plugs because more fuel and bigger injectors will cause them to foul really fast a tune can correct this.....What mods do you have?
Offline   Reply With Quote
Old 07-07-2009, 10:49 AM   #3 (permalink)
 
Registered: Jun 2009
Posts: 4
Reputation: dsmgrimreaper is an unknown
yes i have the stock regulator on it now but i have an arromotive regulator just not installed yet and i have not tuned the car yet. im waiting on parts to get here so i can do cams cam gears timing and dynoed. also the car spitts and sputters just slowly increasing the throttle
Offline   Reply With Quote
 
Old 07-07-2009, 10:52 AM   #4 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
that is probably your problem. get the new regulator on there and adjust pressure and tune for your pump, scale the injectors and you should be good. Also change your plugs regardless....
Offline   Reply With Quote
Old 07-07-2009, 11:20 AM   #5 (permalink)
 
Registered: Jun 2009
Posts: 4
Reputation: dsmgrimreaper is an unknown
yeah im going to work on that today. what should i set the pressure at?
Offline   Reply With Quote
Old 07-07-2009, 11:33 AM   #6 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
That i'm not sure since i'm running almost all stock except the pump
Offline   Reply With Quote
Old 08-06-2009, 05:12 PM   #7 (permalink)
 
Registered: Jun 2009
Posts: 4
Reputation: dsmgrimreaper is an unknown
well new problem got a tactrix cable and evoscan data logger and i cant get it to download the drivers dont know why it ask for a disc and if i try searching it gives me error code 28.
Offline   Reply With Quote
Old 08-06-2009, 07:01 PM   #8 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
thats not good did you get the right tactrix cable? some of them are for the newer model mitsus.....also some versions of ecuflash have given me trouble. take it somewhere and get tuned properly if you cant get it to work or email the people at evoscan...but you will need ecuflash from openecu.org to retune your car.
Offline   Reply With Quote
Old 12-02-2009, 03:31 PM   #9 (permalink)
EVOtuners Member
 
Club Region: Mid Atlantic
Registered: May 2007
Posts: 11
Reputation: MadMsheen is an unknown
Send a message via AIM to MadMsheen
Your plugs are fouled. You need to have the injector latencies dialed in for the new 750s. Until you get them dialed in, your new plugs will get fouled just as quickly.

Edit: Looks like SicLanEvo already got it.


__________________
Where I hang: DCEvoclub.com
Offline   Reply With Quote
Old 12-02-2009, 05:25 PM   #10 (permalink)
EVOtuners Member
 
Car: 06 EVO
Club Region: Tri State
Registered: Sep 2008
Posts: 7
Reputation: is3turbo is an unknown
Thumbs up hey guys chekout my litle project

wellll its not done yet tho but let me know wat yalll think
Offline   Reply With Quote
Old 03-30-2012, 10:05 PM   #11 (permalink)
EVOtuners Member
 
Car: 07 EVO
Club Region: SoCal
Registered: Mar 2012
Posts: 1
Reputation: MPGguru is an unknown
The entire fuel system could use a good cleaning. There's a new technology called the SMART Emissions Reducer by Extreme Energy Solutions.

Many people seem to be getting cleaner and more efficient fuel consumption as well as better gas mileage. The first month its installed it cleans out the entire system before really boosting performance. It might be worth a look.
Offline   Reply With Quote
Old 02-28-2013, 05:19 AM   #12 (permalink)
EVOtuners Member
 
Car: 03 EVO
Club Region: Southeast
Registered: May 2012
Posts: 4
Reputation: Tonyevo8 is an unknown
I just got some new pte 1600cc injectors but no scale n latecy on it. Can anyone tell me how i can get it? Please be specific on where and what site to go to. Im not good with computer findings. Thanks
Offline   Reply With Quote
Old 03-17-2013, 07:22 AM   #13 (permalink)
EVOtuners Member
 
Club Region: Outside North America
Registered: Jan 2013
Posts: 3
Reputation: Josephrogers is an unknown
Quote:
Originally Posted by Tonyevo8 View Post
I just got some new pte 1600cc injectors but no scale n latecy on it. Can anyone tell me how i can aftermarket parts get it? Please be specific on where and what site to go to. Im not good with computer findings. Thanks
Get to sites like ebay and amazon. You will get these injectors

Last edited by Josephrogers; 03-17-2013 at 09:18 PM.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 03:27 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.