Timing Problem, Need Help! - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Tuning & Engine Management
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Tuning & Engine Management Engine Management, EGT temps, timing, wideband, datalogging, fuel trims, etc.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 07-22-2005, 10:27 PM   #1 (permalink)
 
Registered: Dec 2004
Posts: 4
Reputation: hybridboost is an unknown
Timing Problem, Need Help!

Im posting this for a friend who doesn't have any internet. Hes having some issues with his car overheating due to the timing. Hes got a Greddy t-66 turbo kit on it as well as 3in exhaust and Unorthodox cam gears. His Autronics engine management is set 15 degrees at idle however, when using the timing light his crank pulley doesen't match up to that all the time. It'll show 15 degrees then all of a sudden the mark will "disappear" then come back to 15. It seems to do this while driving, causing his engine temps to skyrocket. No one has been able to diagnose this problem he is having. He thinks it could possibly be something messed up in his wiring harness. If anyone can help on here that would be great. Thanks!
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-23-2005, 12:11 PM   #2 (permalink)
EVOtuners Member
 
turbolarry's Avatar
 
Club Region: SoCal
Registered: Oct 2004
Posts: 1,577
Images: 10
Reputation: turbolarry is known to be trustworthy and helpfulturbolarry is known to be trustworthy and helpfulturbolarry is known to be trustworthy and helpful
Timing at idle should be 5* (+/-3*)



Offline   Reply With Quote
Old 07-24-2005, 04:38 AM   #3 (permalink)
 
Registered: Dec 2004
Posts: 4
Reputation: hybridboost is an unknown
Well they want it at 15 I guess. But why would it change like that?
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 05:56 PM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.