A/C problem(fan relay) - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Non-Performance Tech
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Non-Performance Tech Interior, exterior, appearance mods, lighting, alarms, car audio, etc.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 02-14-2011, 05:08 AM   #1 (permalink)
EVOtuners Member
 
Car:
Club Region: Mid Atlantic
Registered: Jan 2011
Posts: 4
Reputation: jansengeorge is an unknown
A/C problem(fan relay)

Ok, I have searched and searched here, have read about this same problem many times, but didn't take it all in, cause I didn't think I would need it.

My cooling fan kicks on and off while running the AC constantly, doesn't stay on or off, runs 2 seconds off, 2 seconds on, 2 seconds off, constantly while running the AC at idle, why? Is it the A/C fan relay?

If anyone might know, please lend me a hand.

Thank

Last edited by jansengeorge; 02-14-2011 at 05:13 PM.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2011, 04:14 PM   #2 (permalink)
Moderator
 
Car: 03 EVO
Club Region: Mid Atlantic
Registered: Aug 2005
Posts: 1,289
Images: 7
Reputation: You can trust this leader of the site
Send a message via AIM to SicLanEvo
what kind of car do you have since it says 04 non-evo?

the lancers and evos had a fan control module TSB that should have been taken care of already.


__________________
discounttiredirect.com
eibach.com
LB Design
Offline   Reply With Quote
Old 04-12-2012, 04:55 AM   #3 (permalink)
EVOtuners Member
 
Club Region: New England
Registered: Apr 2012
Posts: 2
Reputation: usopp is an unknown
Quote:
Originally Posted by jansengeorge View Post
Ok, I have searched and searched here, have read about this same problem many times, but didn't take it all in, cause I didn't think I would need it.

My cooling led fan kicks on and off while running the AC constantly, doesn't stay on or off, runs 2 seconds off, 2 seconds on, 2 seconds off, constantly while running the AC at idle, why? Is it the A/C fan relay?

If anyone might know, please lend me a hand.


Thank
Did you try replacing your fan with a new one?

Last edited by usopp; 04-13-2012 at 12:05 AM.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 07:15 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.