possible electrical probelm - Mitsubishi Evolution Forums: Mitsubishi Lancer Forum
Mitsubishi Evo Forum Mitsubishi Evo Forum Header Right
 

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mitsubishi Evolution Forums: Mitsubishi Lancer Forum > Lancer Evolution Tech Forums > Non-Performance Tech
Register Forum Active Topics (T) Gallery Auto Loans Classifieds Garage Mark Forums Read Auto EscrowInsurance Advertise

Non-Performance Tech Interior, exterior, appearance mods, lighting, alarms, car audio, etc.

EvoTuners.net is the premier Mitsubishi Evolution Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 03-20-2011, 03:43 PM   #1 (permalink)
EVOtuners Member
 
Car: 03 EVO
Club Region: Outside North America
Registered: Mar 2011
Posts: 1
Reputation: Sophia is an unknown
Question possible electrical probelm

Hi All

I need some help for an evo 8 03. ...half the lights on the dash started going on and off last week its not a flickering though...ill turn the car on and half of the lights wont come on till maybe an hour into driving.

Its been pouring down rain over here aswell and the car did something very odd last night. All 3 of the tarmac, gravel snow lights went on last night the gearbox became very hot and the car started jolting a little whle changing gears. Turned the car off and back on all is normal now.

Anyone got any ideas on what copuld be happening?

your help would be great
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-12-2012, 05:01 AM   #2 (permalink)
EVOtuners Member
 
Club Region: New England
Registered: Apr 2012
Posts: 2
Reputation: usopp is an unknown
Quote:
Originally Posted by Sophia View Post
Hi All

I need some help for an evo 8 03. ...half the led lights on the dash started going on and off last week its not a flickering though...ill turn the car on and half of the lights wont come on till maybe an hour into driving.

Its been pouring down rain over here aswell and the car did something very odd last night. All 3 of the tarmac, gravel snow lights went on last night the gearbox became very hot and the car started jolting a little whle changing gears. Turned the car off and back on all is normal now.

Anyone got any ideas on what copuld be happening?

your help would be great
Where are you from? I may get you some help

Last edited by usopp; 04-13-2012 at 12:07 AM.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -8. The time now is 07:44 AM.


vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2007 AutoForums.com - EVOtuners.net - All Rights Reserved.

Powered by vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.