Mitsubishi Lancer Evolution Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Hey guys, listen i would like to thank for any help in advance....here is the situation:

05 Evo VIII
Mods:
AMS fmic
AMS licp
Turbosmart dual port bov
Turbosmart E boost 1
Apexi intake
SAFC1(not in use but in the car-values at 0)
Koyo Radiator
Megan Racing:
Exhaust mani
o2 housing
downpipe
testpipe
exhaust straightpipe
(all 3 in back)
STOCK turbo
stock fuel pump and injectors
Apexi Turbo Timer

ok guys so all of the exhaust stuff was just recently put on due to a small front end accident including the fmic and licp and radiator everything else was already on the car and was fine before then.

INCIDENT:i get the car back. driving from a stop taking of full throttle in 1st and 2nd gear everything is fine.

During a full throttle pull in 3rd and 4th gear boost kicks in im holding strong at 20 psiup until about 5 to 6k rpms then the boost shoots up smacks 22 to 23 sometimes higher and hits fuel cut.

I cant for the life of me think of what the hell could be causeing this. A few things i have checked....

Wastegate visual inspection is good.
All hoses and couplings look good and no leaks.

Things that cause concern:
The shop replaced pass side motor mount....the one where the timeing belt is (timing?)
The shop pulled the car onto the frame machine with no intake or radiator on the car.

Im assuming this is boost creep? Am i wrong could anyone point me in the right direction?

Thanks guys
Jey - "Team Trinity" :thumb:
 

·
Premium Member
Joined
·
1,566 Posts
There is more air coming in then the ECU is programmed to deal with. Get a hold of a logger and see if you can reduce some of that air the ECU sees with the AFC. If not, it's just time for more fuel; injectors/pump.
Did you connect the Apex TT so it can read O2 values/theortical AFR's?
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #4 ·
turbolarry said:
There is more air coming in then the ECU is programmed to deal with. Get a hold of a logger and see if you can reduce some of that air the ECU sees with the AFC. If not, it's just time for more fuel; injectors/pump.
Did you connect the Apex TT so it can read O2 values/theortical AFR's?

Ok man thanks for your help guys, boost controller is running fine.
What i did....ill put up the readouts tomorrow morning but basically i figured takeing the advice on too much air to the ecu? was a good call so i went and started tuning the AFC in the RPM range that was giving me the problem....

Basically starting to richen it up at eventually max what i wanted to do with no logger, i didnt go above 10% in any rpm range.
When i richened it up +1% at a time it would start doing it earlier in the power band downward to the 4k rpm range so i desided , the sound the exhaust was making sounded extremely rich so i decided to go the other way....

I leaned it out a little and ended up loosing the main "fuel cut" prob. right now it reads around this: (ill have axact numbers tomorrow.)....
4k- -2%
45- -4%
5k- -6%
5.5- -8%
6k- -10%
65- -10%
7k- -10%
7.5- -10%

This was in high throttle not low. The car is running beautifully and the fuel cut is gone. Does this make sence? didnt i just loose more fuel at those rpm ranges??? i will get a logger and a tune as soon as the cams are in the car as well.

Now onto the boost creep prob......It isnt highly over boosting anymore i have it holding strong at about 19.5 psi and the highest creep i get is around 20.1 to 21.0 psi. However one thing i do notice for those who know about the EBOOST it has a control for the wastegate, i have it set to open at 2.9 psi and if i hold it closed longer there is NO difference.(it should be a ton quicker spool) but it spools quick as shit in low rpms already and i shouldnt be hitting full boost this soon. im hitting full boost before 3k actually in second im hitting full spool at 2600 or 2700 rpms.??????

Wastegate problem?-but the major spikes are gone. and the cel light went off now too.

Thanks again for any help guys its really opreciated.

PS that is a no on the setting the TT for O2 readings , its crap....<----from Apex lol not acurate readings.
Jey
Team Trinity :thumb:
 

·
Premium Member
Joined
·
1,566 Posts
MOMOJeyEvlEvo said:
PS that is a no on the setting the TT for O2 readings , its crap....<----from Apex lol not acurate readings.
Jey
Team Trinity :thumb:

Since you haven't logged it to really see what's going on, at least get the O2's of the turbo timer. It will give you some idea of what's going on. It's only good for your own car, and yea it's not the most accuate thing, but it will give you at least a "ball park" for now.
Scroll down to Interpreting O2 Sensor Voltage Readings (basically the same as a 2g);
http://www.roadraceengineering.com/instructions/autotimer.htm
 

·
Registered
Joined
·
37 Posts
MOMOJeyEvlEvo said:
Now onto the boost creep prob......It isnt highly over boosting anymore i have it holding strong at about 19.5 psi and the highest creep i get is around 20.1 to 21.0 psi. However one thing i do notice for those who know about the EBOOST it has a control for the wastegate, i have it set to open at 2.9 psi and if i hold it closed longer there is NO difference.(it should be a ton quicker spool) but it spools quick as shit in low rpms already and i shouldnt be hitting full boost this soon. im hitting full boost before 3k actually in second im hitting full spool at 2600 or 2700 rpms.??????
So you're tuning blindly and went from + adjustments to - adjustment. Sweet. Inducing fuel cut due to a blind tune, tuned by the seat of the pants. Now you have diagnosed your boost controller as "fine" by what? Looking at it? It is evident that you really know little about tuning or your car. Once again, it is the boost controller. EVO's DO NOT BOOST CREEP, PERIOD. It is boost controller related. What do I know about Evos.....
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #7 ·
DSM95Hybrid said:
So you're tuning blindly and went from + adjustments to - adjustment. Sweet. Inducing fuel cut due to a blind tune, tuned by the seat of the pants. Now you have diagnosed your boost controller as "fine" by what? Looking at it? It is evident that you really know little about tuning or your car. Once again, it is the boost controller. EVO's DO NOT BOOST CREEP, PERIOD. It is boost controller related. What do I know about Evos.....
Hey listen man i know u got a great car and i do want to oppologize for the way i said the boost controller is fine. i Meant.....The boost controller is fine, tested and set up by Turbosmart and checked for all functionality. I do know that evos do boost creep ive done months of reading and reading on thisand have seen related problems with others evos. Did u read the mods i have done? Also i do believe the problem is the wastegate and ill be getting that to the dealership so they can test it for me. Thanks again for your help guys i oppreciate it. (but please dont be on here to bash me and tell me what i am and am not good at.) Ive blind tuned but i know what to look and listen for and what readings to go by.

thanks, jey
Team Trinity :thumb:
 
1 - 7 of 7 Posts
Top