Mitsubishi Lancer Evolution Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
i had a cel and i got the codes pulled and i got catalyst efficiency below threshold and engine overboost condition. I have a 3 inch tbe w/ highflow cat and an open element filter. Are they either somethin to worry about, can someone explain what overboost is to me. I think the cat efficiency is because of the the high flow cat. Can overoost be because its like 10 degrees out or what, lil help please
 

·
Premium Member
Joined
·
3,592 Posts
Did you do any CEL fixes when you installed the exhaust? Some HFCs cause a CEL and some don't, but there's a couple of easy fixes for it. I'm not sure on the overboost, but since you don't have boost control, you do have an exhaust, and it is cold, it may be causing a boost spike.

Turbolarry, any experience with the overboost CEL? Carkid, for now, you might want to disconnect the battery and let it reset...then see if those CELs come back. You can do a fix for the cat CEL, but the overboost one should go away after a reset, I believe.
 

·
Registered
Joined
·
134 Posts
Discussion Starter · #3 ·
thx for the info, u mentioned fixes for the cat cel, would that just be a o2 sim? or are there other things i can do, thats really the least of my worries though, i will let it sit unplugged for a day or 2 and see how that goes. thx for the info and help
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top