Mitsubishi Lancer Evolution Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Didnt see this on these forums anywhere, so. Just wondering, i put larger injectors in. So using the tuning guide on these forums, i decreased fuel in low and high. So now im trying to get the fuel trims to 0%. Anyone know about how long does this take? I was sitting there for awhile they didnt seem to change much. Even after i increased fuel at idel. Thanks for any input.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Ok, i reset the ecu. I think that had something to do with it. But im running 780 injectors, 280 cams turbo kit all the other stuff. In order for me to get the ST to near 0 i had to add fuel into the positive range. In the setup i followed base adjustments for 780s is -36 in all rpm ranges. So now if i follow these settings for 0 ST/ LTFT i think is like 16% pos. in all hi/lo ranges i wont be able to get any timing. This just dosent sound right to me. I mean 780s are pretty frekin big. to have to add that much fuel? Sounds crazy. But i tried a WOT in3rd and its getting way to much fuel. Stumbeling stutering. Even at idel u can smell un burnt fuel, u should see my bumper. Maybe ill reset the ecu again and start at the recommended750 or 720 injector setup. Any input? thanks
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Thanks, I was thinkin the same thing. Maybe low throttle has something to do with the overlap of the cams, with needing the extra fuel. I have an RNR 50 trim kit. I think i'll start with around 13psi and go from there with hi/ settings. See how it goes 2morrow. I think my lo/ settings are around +16 or 17. Its tough to get those ST fueltrims at 0% since they move around so quick. They range frm +5 to -5 in lo setting at each rpm, is that good enough to get 0% LT?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Well finally got my log viewer to work on the PC. Im wondering if i should be seeing a drop in timing at 4500rpms? Its at 14, then after 4500 it increases nicley to 21 at about 6750. O2 is .92-.94. How it is now im running 15.5 psi. As long as that dip is normal "i thought i read somwhere that it is" I would like to keep tunning to the stock turbo boost of 19psi. All on 94 sunoco. Then when the alky kit comes tune it some more. BTW, props to turbolarry for all the help. Oh yeah, at 15.5 this car is sick. I had my girlfriend hitting the go and stop button on the logger today. Of the 2 runs i had time for today, she said she never got pushed back into the seat like that before.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
Yeah full boost hits like right at 4500. Almost exactly, the external w/g opens at 4500. Anyway, if i were to see a fall in timing anywhere else i would just add a couple % of fuel to the equation correct? Just makin sure. When i first got my SAFC, it was 2 years ago and came with the Buschur settings so i just set it and left it. Never really messed with it untill lately. Thanks for all the help.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
Yeah its a thrust bearing. Dry cartridge. Its not mydaily driver, so it dosent matter to me much. Maybe some time ill give the BB turbo a shot. Or maybe the buschur 20/21g. But this thing has alot of headroom so . Is there a way to tell if its rich knock? Also in the lower RPMs in my 3rd gear pulls my O2 volts are like .88 is that safe? This is before and during spool.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #14 ·
This is off topic from my original post, just 2 let u know. Right now i am using an SAFC1. I am wondering if the wiring for an afc2 is different? Also will the harness that comes with the SAFC2 plug right into the harness that came with the 1 and is already hooked up to my ecu harness? With out moving wires around. Thanks
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top