Mitsubishi Evolution Forums: Mitsubishi Lancer Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
I installed my greddy turbo timer today. Only problem is when i shut the key off to ACC it keeps the car running. But when i go back to lock to take the key out the car shuts off. You turn the key to off and the timer says "OFF". So it's not like it's just dying either.

One more thing i noticed is that when i turn it to ACC it is not turning on. It wont turn on untill the key is at ON. The directions mention it turning on at ACC so i assume this could be part of the problem.

Btw i have the Plug and play harness.

Any ideas?
 

·
Registered
Joined
·
133 Posts
Discussion Starter #3
is the e-brake thing needed? I didnt think it was, thats not hooked up.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #6
plugged in the e-brake wire, same thing. Switched line modes to both. Same. This is gettin upsetting. I know its hooked up right because when i turn the key to "lock" the TT says off, like its turning off, it doesnt just die. Man, ill try to find someone who can see in person whats goin on and fix me up. Thx for ur help again larry, i appriciate it. Thx big time btw for the english manual!!
 

·
Premium Member
Joined
·
1,284 Posts
mine only took me about 20 minutes to hook up. i had no problems with it at all and i was using the harness from my 2g eclipse. make sure the ebrake connection is hooked up and then flip the switch on the back of the unit.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #9
ive been screwin with this from half a freakin year and i havent figured it out. Ive fliped the switch on the back, changed the ig to acc numerous times, the only things i havent done are take the steering column back off and look in there, and i havent connected it to the speed sensor, but i was told u didnt have to... i think im going to do it this wekeend though. I know its somethin stupid im doin, it ain the product. 95% sure.
 

·
Registered
Joined
·
19 Posts
i tried all of this the thing works pretty much like if i put down the e brake itll shut the car off all the functions work its just if i turn the key back all the way it doesnt stay running and if i take out the key it doesnt stay running

i checked everything numerous times im just so confused
 

·
Registered
Joined
·
19 Posts
yea its not a fake one the functions are working correctly ebrake goes down the car shuts off, its reading the speed function correctly, i can even set it its just shutting off the car when i take the key out
 
1 - 12 of 12 Posts
Top