Mitsubishi Lancer Evolution Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 · (Edited)
Hey, i was down in my garage using a voltmeter checkin my fuses under my steerin wheel when i noticed my radio didnt work. It doesnt even power on. I didnt probe anywhere in the cubbyhole "where my tt was" or where those factory gauges come in 05's. I checked every fuse on the car all are good besides my heated mirror one which i didnt even know i had. Whats wrong? i did the best i could for checking wires goin to the headunit and lookin for cracks or unplugged wires. Stock headunit, didnt touch anything inside besides to hook up my boost gauge light which was a few months ago, and my tt which was longer than that. Help me get it workin!

p.s. how do u get the plastic moulding off that surrounds the headunit and the fan controls, i had 4 screws out. The two on the bottom holding the cubbyhole, and the two behind the knobs, whatelse is there. If i find that out ill check behind the radio, and everything.

***** OH *****

btw, the clock doesnt work either at all or the keyless entry that the car came stock with. No flashing lights, and it doesnt lock or unlock it. Also my trip odemeter resets itself everytime i start the car
 

·
Premium Member
Joined
·
718 Posts
CArkid0101 said:
btw, the clock doesnt work either at all or the keyless entry that the car came stock with. No flashing lights, and it doesnt lock or unlock it. Also my trip odemeter resets itself everytime i start the car
In the fuse box under the hood is a set of fuses that are joined together in a plastic clip that slides up and down used by the dealership to disable the radio, dome light, clock and a couple other things to keep people from running the battery down when a car is on the show room floor.

Either that clip is in the up position removing the fuses from contact, or one of them is blown.

Keith
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #6 ·
Could it be a factory ground behind the radio anywhere because i notice i have acc 12v when the key is off and out. My hid's would stay on till i opened my door and now they turn off right away, and my odometer resets.
 
1 - 6 of 6 Posts
Top