Mitsubishi Lancer Evolution Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
hey how you doin i have an evo 8 and has about 24,000 on it after 11,000 i started to notice that the turbo wasn't at full boost 2500 rpm now at 24,000 i have turbo lag from 2500 to 3300 at full boost i have no idea what could cause this. i took the intake off and checked for shaft play put it was sturdy and spun freely can you guys help me out
:cry:
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
my bad, when i first bought my brand new evo i used to have full boost at 2500 rpms now the car has 25,000 miles on the engine and i don't have full boost until 3200 rpm. what do you think is the problem
 

·
Premium Member
Joined
·
1,566 Posts
power_bulge said:
my bad, when i first bought my brand new evo i used to have full boost at 2500 rpms now the car has 25,000 miles on the engine and i don't have full boost until 3200 rpm. what do you think is the problem
It sounds like there was a problem before when it was reaching full boost at 2500. That is definatly not the norm. 3200 is where I hit ful boost.
 

·
Premium Member
Joined
·
3,496 Posts
Yeah, no USDM Evo hits full boost at 2500rpm. I think you must have been on some meds or something, because even 3200rpm is VERY EARLY. I hit full boost around 3600-3700rpm in 3rd gear. Of course, putting it in top gear and flooring it causes more load, which spools it earlier, but I don't ever refer to 6th gear spool as where I hit "full boost." Even in 6th gear or so, 3200rpm is pretty damn early. I'd be very happy if I were you, because full boost at 3200rpm is awesome. Complaining about turbo lag from 2500-3200 is pretty funny...:)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
thanks fellas i just want to make sure i have no boost problems but also when i rev the car and start boosting and ease of the gas it makes a ticking sound only hapens when i boost.
 
1 - 7 of 7 Posts
Top