Mitsubishi Lancer Evolution Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Ok so recently i just added a few more mods to my car. My list of mods so far is an hks hi power exhaust, forge recirc valve, hks rs intake, hallman mbc, and a dynoflashed ecu. After i got the ecu back the car ran great for two weeks hittin 20psi all the way through redline. But two nites ago the car started doing something weird... it hits 10 psi and it does this weird flutter. Its not a direct cut because it will go past 10psi but every 2 psi after that it loses power. It almost feels like a misfiring cylinder. I checked every connection and hose and what not but there is no leak that i can find. My check engine came on this morning on the way to work so i am going to go get that checked out. My question is does anybody have any opinions on this topic. Please let me know thanx
PJ
 

·
Registered
Joined
·
26 Posts
The flutter is your Forge Recirc Valve (at least if it is the same as in VW type 007 or 006) That vavle tends to leaks some at 22psi+ this causes the piston in the valve to flutter by the vent port in the valve letting short little burst of air out thus making the flutter.
 

·
Premium Member
Joined
·
1,566 Posts
Is the forge valve adjustable/have differnt springs? It might not be sealing all the way and need further adjusting. Post the code too when you get a chance.
 

·
Registered
Joined
·
26 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
you guys ready to laugh. All this time it was my spark plug. It had gotten dirty and i had to clean it and it was fine. THANK GOD :thumb: . So everything worx fine now and the car is runnin awesome. Thanx for your input. :dsm: :dsm:
 

·
Registered
Joined
·
26 Posts
Glad to hear she's running better now.
 
1 - 6 of 6 Posts
Top