Mitsubishi Lancer Evolution Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter · #1 ·
Ok, so I decided to buy the ebay ss o2 housing from SS autochrome. The problem is they are showing 2 different pictures with the o2 sensor located in a different spot, and from a post I read over on EvoM they are sending out the housing with sensor in a bad location. Supposedly has a hard time reaching and something gets in the way. Ya, I have no idea what... I forgot.

So they put the first pick up on ebay, but if you look at the bottom picture that is what they are shipping out. Notice the O2 sensor isn't in the same location as the original picture, or the one from Buschur (and buschur just uses these but addes a ceramic coat)

http://cgi.ebay.com/ebaymotors/Mits...742QQitemZ150100704758QQrdZ1QQsspagenameZWDVW

Anyone got any other bright ideas :p

I guess I could try one of the "other" ebay ones since they all look the same.
 

·
Premium Member
Joined
·
1,566 Posts
I just looked at the stock O2 housing I have in my garage. The stock sensor location is down lower by the downpipe flange. I haven't installed my Megan one so I can't tell for sure is it would make a difference. :confused:
 

Attachments

·
Registered
Joined
·
70 Posts
larry, from that angle it doesnt look like you are going to get a lot of exhaust flow across the o2 sensor. I wonder if that is going to cause imaccurate readings? maybe Im just looking at it weird?!?
 

·
Registered
Joined
·
137 Posts
I have this installed on my car and it replaced the stock one. No problems. A CEL was tossed up that I cleared after checking the code and found it to be caused by the installer not resetting the ECU after the install, and it never came back since
 
1 - 5 of 5 Posts
Top